Commit 9a3248c0 authored by Mark van Renswoude's avatar Mark van Renswoude

Updated ALL the packages!

parent f95aa0e3
{
"plugins": [
"syntax-dynamic-import",
"transform-es2015-arrow-functions",
"transform-es2015-shorthand-properties",
"transform-es2015-block-scoping"
]
}
\ No newline at end of file
{ "presets": ["@babel/preset-env"] }
\ No newline at end of file
......@@ -34,23 +34,19 @@ class Repository
return store;
};
mkdirp(self.config.path, (err) =>
{
if (err)
mkdirp(self.config.path)
.then(() =>
{
reject(err);
return;
}
self.users = new UserRepository(initStore('user.db'));
self.codes = new CodeRepository(initStore('code.db'));
self.uploads = new UploadRepository(initStore('upload.db'));
self.notifications = new NotificationRepository(initStore('notification.db'));
self.users.init()
.then(() => { resolve() })
.catch((e) => { reject(e); });
});
self.users = new UserRepository(initStore('user.db'));
self.codes = new CodeRepository(initStore('code.db'));
self.uploads = new UploadRepository(initStore('upload.db'));
self.notifications = new NotificationRepository(initStore('notification.db'));
self.users.init()
.then(() => { resolve() })
.catch((e) => { reject(e); });
})
.catch((e) => { reject(e); });
});
}
}
......
This diff is collapsed.
......@@ -16,66 +16,69 @@
"author": "Mark van Renswoude <mark@x2software.net>",
"license": "Unlicense",
"dependencies": {
"@babel/core": "^7.8.7",
"@babel/preset-env": "^7.8.7",
"@fortawesome/fontawesome": "^1.1.8",
"@fortawesome/fontawesome-free-regular": "^5.0.13",
"@fortawesome/fontawesome-free-solid": "^5.0.13",
"@fortawesome/vue-fontawesome": "0.0.22",
"async": "^2.6.1",
"async-retry": "^1.2.3",
"@fortawesome/fontawesome-svg-core": "^1.2.27",
"@fortawesome/vue-fontawesome": "0.1.9",
"async": "^3.2.0",
"async-retry": "^1.3.1",
"babel-polyfill": "^6.26.0",
"bcrypt": "^1.0.3",
"body-parser": "^1.18.3",
"cookie-parser": "^1.4.3",
"debug": "^3.2.5",
"diskusage": "^0.2.4",
"ejs": "^2.6.1",
"email-templates": "^3.6.1",
"es6-promise": "^4.2.5",
"express": "^4.16.3",
"bcrypt": "^4.0.1",
"body-parser": "^1.19.0",
"cookie-parser": "^1.4.5",
"debug": "^4.1.1",
"diskusage": "^1.1.3",
"ejs": "^3.0.1",
"email-templates": "^7.0.4",
"es6-promise": "^4.2.8",
"express": "^4.17.1",
"express-async-handler": "^1.1.4",
"js-cookie": "^2.2.0",
"jsonwebtoken": "^8.3.0",
"lodash": "^4.17.11",
"js-cookie": "^2.2.1",
"jsonwebtoken": "^8.5.1",
"lodash": "^4.17.15",
"markdown": "^0.5.0",
"mkdirp": "^0.5.1",
"moment": "^2.22.2",
"mkdirp": "^1.0.3",
"moment": "^2.24.0",
"mz": "^2.7.0",
"nanoid": "^1.2.3",
"nanoid": "^2.1.11",
"nedb": "^1.8.0",
"nodemailer": "^4.6.8",
"npm": "^5.10.0",
"pug": "^2.0.3",
"nodemailer": "^6.4.5",
"npm": "^6.14.2",
"pug": "^2.0.4",
"resolve-path": "^1.4.0",
"tus-node-server": "^0.2.11"
"tus-node-server": "^0.3.2"
},
"devDependencies": {
"axios": "^0.18.0",
"babel-loader": "^7.1.5",
"axios": "^0.19.2",
"babel-loader": "^8.0.6",
"babel-plugin-syntax-dynamic-import": "^6.18.0",
"babel-plugin-transform-es2015-arrow-functions": "^6.22.0",
"babel-plugin-transform-es2015-block-scoping": "^6.26.0",
"babel-plugin-transform-es2015-shorthand-properties": "^6.24.1",
"css-loader": "^0.28.11",
"css-loader": "^3.4.2",
"dart-sass": "^1.25.0",
"fibers": "^4.0.2",
"file-loader": "^1.1.11",
"file-loader": "^6.0.0",
"html-webpack-plugin": "^3.2.0",
"purecss": "^1.0.0",
"purecss": "^1.0.1",
"sass": "^1.26.3",
"sass-loader": "^7.3.1",
"style-loader": "^0.20.3",
"tus-js-client": "^1.5.1",
"uppy": "^0.23.3",
"vue": "^2.5.17",
"vue-i18n": "^7.8.1",
"vue-loader": "^14.2.3",
"vue-router": "^3.0.1",
"sass-loader": "^8.0.2",
"style-loader": "^1.1.3",
"tus-js-client": "^1.8.0",
"uppy": "^1.10.1",
"vue": "^2.6.11",
"vue-i18n": "^8.15.5",
"vue-loader": "^15.9.0",
"vue-router": "^3.1.6",
"vue-style-loader": "^4.1.2",
"vue-template-compiler": "^2.5.17",
"webpack": "^4.19.1",
"webpack-bundle-analyzer": "^2.13.1",
"webpack-cli": "^2.1.5",
"webpack-dev-middleware": "^3.3.0",
"webpack-hot-middleware": "^2.24.0"
"vue-template-compiler": "^2.6.11",
"webpack": "^4.42.0",
"webpack-bundle-analyzer": "^3.6.1",
"webpack-cli": "^3.3.11",
"webpack-dev-middleware": "^3.7.2",
"webpack-hot-middleware": "^2.25.0"
}
}
......@@ -6,7 +6,7 @@ import App from './App.vue';
import messages from './lang';
import shared from './shared';
import fontawesome from '@fortawesome/fontawesome';
import FontAwesomeIcon from '@fortawesome/vue-fontawesome';
import { FontAwesomeIcon } from '@fortawesome/vue-fontawesome';
import moment from 'moment'
import merge from 'lodash/merge';
......
......@@ -34,13 +34,6 @@ export default {
y: '0 years | 1 year | {count} years'
},
uppyDashboard: {
done: 'Done',
dropPaste: 'Drop files here, paste or',
browse: 'browse'
},
admin: {
loading: 'Loading…',
empty: 'No data',
......
......@@ -34,12 +34,6 @@ export default {
y: '0 jaren | 1 jaar | {count} jaren'
},
uppyDashboard: {
done: 'Gereed',
dropPaste: 'Sleep bestanden, plak of ',
browse: 'selecteer'
},
admin: {
loading: 'Bezig met laden…',
......
......@@ -72,7 +72,7 @@ export default {
</script>
<style lang="scss">
@import '~uppy/src/scss/uppy.scss';
@import '~uppy/src/style.scss';
#landing
......
......@@ -25,9 +25,9 @@
<script>
import map from 'lodash/map';
import shared from '../shared';
import Uppy from 'uppy/lib/core';
import Dashboard from 'uppy/lib/plugins/Dashboard';
import Tus from 'uppy/lib/plugins/Tus';
import Uppy from '@uppy/core';
import Dashboard from '@uppy/Dashboard';
import Tus from '@uppy/tus';
import axios from 'axios';
export default {
......@@ -81,14 +81,7 @@ export default {
.use(Dashboard, {
inline: true,
target: '.uploadTarget',
replaceTargetContent: true,
locale: {
strings: {
done: self.$i18n.t('uppyDashboard.done'),
dropPaste: self.$i18n.t('uppyDashboard.dropPaste'),
browse: self.$i18n.t('uppyDashboard.browse')
}
}
replaceTargetContent: true
})
.use(Tus, {
endpoint: '/upload/',
......
const path = require('path');
const webpack = require('webpack');
const VueLoaderPlugin = require('vue-loader/lib/plugin');
const HtmlWebpackPlugin = require('html-webpack-plugin');
const BundleAnalyzerPlugin = require('webpack-bundle-analyzer').BundleAnalyzerPlugin;
const Fiber = require('fibers');
......@@ -34,8 +35,7 @@ module.exports = (env, options) => {
{
loader: 'sass-loader',
options: {
implementation: require("sass"),
fiber: Fiber
implementation: require("sass")
}
}
],
......@@ -71,7 +71,8 @@ module.exports = (env, options) => {
plugins: [
new HtmlWebpackPlugin({
template: path.resolve(__dirname, './public/src/index.html')
})
}),
new VueLoaderPlugin()
],
resolve: {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment